Repository navigation
chore: update minimum Rust version from 1.96.0 to 1.97.0 - #29
Merged
Merged
Conversation
Co-Authored-By: Devin AI <158243242+devin-ai-integration[bot]@users.noreply.github.com>
Contributor
Author
|
I'll fix CI failures and address comments from users with write access. I'll skip comments containing "(aside)".
|
Contributor
Author
|
@cursor review |
kinyoklion
marked this pull request as ready for review
October 12, 2026 17:40
kinyoklion
approved these changes
Oct 12, 2026
jsonbailey
approved these changes
Oct 12, 2026
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.


Summary
This raises the example's MSRV to 1.97.0, because the daily
Build and runonmainhas been red since 2026-10-08.launchdarkly-server-sdk3.3.0 (latest;>=3.1.1already resolves to it) depends oneventsource-client ^0.18.0.eventsource-client0.18.1, published 2026-10-07, declaresrust-version = "1.97.0".eventsource-client@0.18.1 requires rustc 1.97.0.Cargo.tomlchangesrust-versionfrom1.96.0to1.97.0, andci.ymlchangesrustup override setfrom1.96.0to1.97.0. Nothing else changes; the SDK constraint stays as it is.Verification
Local, on rustc 1.97.0:
cargo clippywithRUSTFLAGS="-W deprecated"produced no warnings.LAUNCHDARKLY_SDK_KEY=… LAUNCHDARKLY_FLAG_KEY=hello-boolean CI=1 cargo run -qprinted:and then the banner.
On rustc 1.96.0 the build fails with the same error as the scheduled CI runs (e.g. run 38127323604).
The
inbox_rx is disconnectedERROR log at shutdown is not new: the last green run on 2026-10-07 shows it too.Link to Devin session: https://app.devin.ai/sessions/738ced6178134242807e7d6c7f0c27e3
Open in Devin Desktop: https://app.devin.ai/desktop/session/738ced6178134242807e7d6c7f0c27e3?variant=devin
Note
Overview
Raises the project minimum supported Rust version from 1.96.0 to 1.97.0 in
Cargo.tomland aligns the Build and run workflow sorustup override setuses 1.97.0.This unblocks CI and local builds where
launchdarkly-server-sdk(viaeventsource-client0.18.1) now requires rustc 1.97.0. Dependency constraints are unchanged.Reviewed by Cursor Bugbot for commit 6abb8ca. Bugbot is set up for automated code reviews on this repo. Configure here.